Redistribute

03.05.19 01:51 AM Bình luận Đăng bởi PQ

I. Tổng quan

1. Redistribute

Redistribute là một phương pháp phân phối một Route được học từ giao thức định tuyến này vào một giao thức định tuyến khác. Redistribute thường được thực hiện trên Router giao tiếp giữa hai giao thức định tuyến khác nhau hay còn gọi  Router biên dịch ASBR (Boundary Router)

Redistribute không chỉ dùng để phân phối giữa các giao thức định tuyến động mà còn có thể phân phối các giao thức định tuyến tĩnh thậm chí Route Connected:

  • Phân phối giữa các giao thức định tuyến động: RIP, EIGRP, OSPF, BGP
  • Phân phối Static Route (Bao gồm cả Static Default Route) vào các giao thức định tuyến động.
  • Phân phối các Route Connected vào giao thức định tuyến động chẳng hạn như các Route Loopback.

Trong Redistribute ta còn có một khái niệm khá quan trọng nữa là Seed Metrics, Seed Metrics là một Metric Default khi mà ta thực hiện Redistribute từ một giao thức định tuyến này vào một giao thức định tuyến khác thì những Route được phân phối ấy sẽ được định nghĩa một Metric Default bằng bao nhiêu đó. Chẳng hạn như đối với giao thức OSPF khi mà ta muốn Redistribute những Route thuộc giao thức định tuyến khác như RIP, EIGRP vào trong giao thức OSPF ấy thì những Route RIP, EIGR sẽ có Metric Default do AS do AS quy định hoặc do chính nhà quản trị quy định.


2. Redistribution: Khi chạy RIPv2, OSPF1, EIGRP,

a. Redistribute vào EIGRP

RIP => EIGRP

Router(config)#router eigrp as-number

Router(config-router)#redistribute rip metric bandwidth delay reliablity load mtu 

EIGRP => EIGRP

Router(config-router)#redistribute eigrp as-number [metric bandwidth delay reliablity load mtu]

OSPF => EIGRP

Router(config-router)#redistribute ospf process-id metric bandwidth delay reliablity load mtu 

Cả  Static Route và Default Route => EIGRP

Router(config-router)#redistribute static [metric bandwidth delay reliablity load mtu]

Connected Route => EIGRP

Router(config-router)#redistribute connected [metric bandwidth delay reliablity load mtu](chỉ quảng bá thông tin vào định tuyến nhưng không trao đổi thông tin với các mạng kết nối)

Trong đó:

  1. Dấu ngoặc vuông [ ] là tùy chọn, có thể có hoặc không.
  2. Bandwidth: tính theo đơn vị kbps (ví dụ đường 10Mbps sẽ là 10000).
  3. Delay: tính theo đơn vị 10 ms (ví dụ 1s là 100)
  4. reliablity: 1="&"gt;255.
  5. Load: 1="&"gt;255.
  6. MTU là đơn vị truyền dữ liệu tối đa.

Các thông số trên trong các bài lab các bạn có thể chọn tùy ý, sau đi làm sẽ có những yêu cầu cụ thể đối với từng thông số này.

b. Redistribute vào OSPF

RIP => OSPF

Router(config)#router ospf process-id

Router(config-router)#redistribute rip [metric cost] subnet.

EIGRP-OSPF

Router(config-router)#redistribute eigrp as-number [metric cost] subnet.

Static route & Default route => OSPF

Router(config-router)#redistribute static [metric cost] subnet.

Connected route => EIGRP

Router(config-router)#redistribute connected [metric cost] subnet.

Default route => OSPF

Router(config-router)#default-information originate.

Nếu chúng ta không đưa vào tham số metric thì mặc định metric sẽ được đặt cho tuyến được redistribute vào là 20.

c. Redistribute vào RIP

EIGRP-RIP:

Router(config)#router rip

Router(config-router)#redistribute eigrp as-number metirc 1. (vì max metric của RIP = 15, nên ta đặt metric cho tuyến được redistribute vào bằng 1 để nó có thể được truyền đi xa nhất có thể trong RIP).

OSPF-RIP

Router(config-router)#redistribute ospf process-id metirc 1.

Static route & Default route => RIP

Router(config-router)#redistribute static metirc 1.

Connected route => RIP

Router(config-router)#redistribute connected metirc 1.

Default route => RIP

Router(config-router)#default-information originate.

II. Thực hành

1. Cấu hình Redistribute giữa giao thức OSPF và EIGRP

a. Yêu cầu chuẩn bị

3 Router Cisco 2621XM

Dây cáp Serial

b. Yêu cầu nội dung

Đấu nối thiết bị như sơ đồ

Cấu hình cơ bản cho Router

Cấu hình trên các Interface

Cấu hình giao thức EIGRP trên R1, R2

Cấu hình giao thức OSPF trên R2, R3

Cấu hình redistribute giữa 2 giao thức EIGRP và OSPF

Kiểm tra kết nối giữa các thiết bị trong mạng

c. Video hướng dẫn

2. Cấu hình Redistribute giữa giao thức OSPF và RIP

a. Yêu cầu chuẩn bị

3 Router Cisco 2621XM

Dây cáp Serial

b. Yêu cầu nội dung

Đấu nối thiết bị như sơ đồ

Cấu hình cơ bản cho Router

Cấu hình trên các Interface

Cấu hình giao thức Ripv2 trên R1, R2

Cấu hình giao thức OSPF trên R2, R3

Cấu hình redistribute giữa 2 giao thức EIGRP và RIP

Kiểm tra kết nối giữa các thiết bị trong mạng

c. Video hướng dẫn

3. Cấu hình Redistribute RIPng với EIGRP

a. Yêu cầu chuẩn bị

3 Router Cisco 1941

2 PC

Dây cáp

b. Yêu cầu nội dung

Đấu nối thiết bị như sơ đồ

Cấu hình cơ bản cho Router

Cấu hình giao thức RIPng trên R1 và R2

Cấu hình giao thức EIGRP trên R2 và R3

Cấu hình Redistribute giữa giao thức RIPng và EIGRP trên R2

Kiểm tra kết nối

c. Video hướng dẫn

4. Cấu hình Redistribute giữa giao thức EIGRP và RIP

a. Yêu cầu chuẩn bị

3 router cisco 2621XM

Dây cáp serial, Ethernet


b. Nội dung công việc cần thực hiện

Kết nối thiết bị theo mô hình để thực hiện các nhiệm vụ cơ bản sau

Đăng nhập vào hệ thống

Đặt mật khẩu truy cập công console của router

Đặt mật khẩu truy cập vào chế Privileged EXEC mode

Đặt mật khẩu truy cập telnet


c. Video hướng dẫn

5. Cấu hình Redistribute RIPng và OSPFv3

a. Yêu cầu chuẩn bị

3 Router Cisco 1941

2 PC

Dây cáp

b. Yêu cầu nội dung

Đấu nối thiết bị như sơ đồ

Cấu hình cơ bản cho Router

Cấu hình giao thức RIPng trên R1 và R2

Cấu hình giao thức OSPFv3 trên R2 và R3

Cấu hình Redistribute trên R2

Kiểm tra kết nối

c. Video hướng dẫn

6. Cấu hình Redistribute EIGRPv6 với OSPFv3

a. Yêu cầu chuẩn bị

3 Router Cisco 1941

2 PC

Dây cáp

b. Yêu cầu nội dung

Đấu nối thiết bị như sơ đồ

Cấu hình cơ bản cho Router

Cấu hình giao thức EIGRPv6 trên R1 và R2

Cấu hình giao thức OSPFv3 trên R2 và R3

Cấu hình Redistribute trên R2

Kiểm tra kết nối

c. Video hướng dẫn

7. Cấu hình Redistribute EIGRPv6 với OSPFv3 RIPng

a. Yêu cầu chuẩn bị

4 Router Cisco 1941

2 PC

Dây cáp

b. Yêu cầu nội dung

Đấu nối thiết bị như sơ đồ

Cấu hình cơ bản cho Router

Cấu hình giao thức RIPng trên R1 và R2

Cấu hình giao thức OSPFv3 trên R2 và R3

Cấu hình giao thức EIGRPv6 trên R3 và R4

Cấu hình Redistribute trên R2 và R3

Kiểm tra kết nối

c. Video hướng dẫn


-----&-----&-----

Để quay về danh sách các bài phần Network các bạn chọn link sau

https://www.quantrimangdn.com/blogs/post/tong-hop-cac-bai-phan-network

Chia sẻ -